agnesa9890
31.12.2022 15:29

Составить программу и его массив (размерность 10), a квадратные из чисел 3,2,5,6,2,0

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
LaiZyHero
25.03.2023 22:04

Казахские узоры имеют конкретное значение и отражают художественное видение окружающего мира. С давних времен орнаменты считались оберегами, которые защищали людей от злых сил, приносили счастье. Ими украшали одежду, ювелирные изделия, жилища, посуду, ковры. Некоторая символика сохранилась до наших дней в неизменном виде. Значение же другой безвозвратно утеряно. Рассмотрим основные символы казахского народа.

Казахские простые орнаменты и узоры Прямолинейные простые символы использовались для создания сложных композиций. До наших дней они дошли в виде росписи на тканях и предметах быта. Это часть преданий и культурного наследия. Некоторые орнаменты и их значение такие: «Балдак». Орнамент напоминает перевернутую ручку костыля. Применяли при росписи войлока. Отождествляется с балдаком — подставкой под руку в виде рогатки, которую использовали во время соколиной охоты. «Балта». Символ напоминает букву «Г» и отождествляется с топором. «Мор». Это равносторонний казахский орнамент, символизирующий стороны света. «Канка». Напоминает хребет животного. Использовался для украшения вязаных вещей и предметов обихода. ЧИТАЙТЕ ТАКЖЕ Чихалка: как правильно пользоваться, толкования по дням Простые казахские орнаменты: UGC Существует множество узоров, каждый из которых дает сотни производных. Известны лишь предпочтения древних казахов в нанесении тех или иных рисунков на предметы, в то время как их точная смысловая интерпретация утеряна. Угловой казахский орнамент, растительные и животные мотивы Наблюдая за явлениями природы, тотемными животными и звездным небом, казахский народ создал сотни орнаментов. Они отождествляли неведомые силы, загадочные и повседневные явления. Рассмотрим распространенные орнаменты и их значение: Зооморфные. Они результат от созерцания поведения тотемных животных. Лошади, верблюды, соколы и бараны оживали в узорах. В дальнейшем воспроизводились отдельные части тела животных: крылья, головы, рога, горбы. В каждом орнаменте можно угадать определенную смысловую отсылку. Растительные мотивы. Растения служили пищей и лекарством выращивать скот. Недаром растительности уделялось такое внимание в древнем мире. Цветы, листья, соцветия и плоды послужили основой для создания орнаментов необычайной красоты. Это легкие казахские орнаменты. Встретить их можно на вышивках, росписи бытовой утвари и сбруи. Космогонические. Смотря на небо, казахи зарисовывали увиденное. Так появились космогоническое орнаменты. На одних — звезды и луна, на других — некоторые природные явления. Как и большинство древних народов.

0,0(0 оценок)
Ответ:
kristina763
25.03.2023 22:04

#include <iostream>

using namespace std;

int main()

{

   int n,summ=0;

cin>>n;

for (int i=1; i<n+1; i++)

{summ=summ+i;}

cout<<summ;

return 0;

Объяснение:

C не знаю. Но на C++ код таков:

#include <iostream>//для cout и cin

#include <cstdlib>//для system("pause");

#include <cmath>//для функции ceil

using namespace std;

int main() {

   setlocale(LC_ALL, "");//русификация

   int p,n,summ=2;

   double k;

   int f=0;

   cout<<"Введите последнее натуральное число для определения суммы всех предыдущих простых, включая заданное:"<<endl;

   cin>>n;

   for (int i=3; i<n+1; i++)

   {

       if (i%2!=0)//если нечётное число, работаем дальше (простых чисел четных нету)

       {

           k=sqrt(i);//корень вычисляем, для отсеивания лишних делителей

           p=ceil(k);//округляем полученное значение в большую сторону

           f++;//само на себя делится в любом случае, поэтому увеличиваем индикатор простоты числа

           //число 1 в этот индикатор не попадает, поскольку мы ищем делители начиная с 2

           for (int j=2; j<=p; j++)//прощупываем все делители

           {

               if (i%j==0)//если делится без остатка на делитель, значит четное. тогда индикатор увеличиваем на один

               {

                   f++;

               }

           }

           if (f<2)//если набежит индикатор меньше одного (а это условие простоты числа), то добавляем его в сумму

           {

               summ+=i;

           }

           f=0;//обнуляем индикатор для последуюшего анализа

       }

   }

   cout<<"Сумма простых чисел до "<<n<<" включительно = "<<summ<<endl;

   system("pause");

   return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота