NaraDarkTheHelp
09.01.2022 02:44

Написать программу, которая считывает два числа a и б, и выдает б-тую цифру числа а! например: число 192345(а) число б = 3, тогда третяя цифра в числе 192345 равняется 2

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
дарханнысанов
29.07.2020 16:16
#include <stdio.h>
int main()
{
int a,b,e,d;
a=192345; //Число
e=5; //Номер цифры
int c[1000000];
d=0;
while(a>0)
{
b=a%10;
d++;
c[d]=b;
a/=10;
}
for(int i=d;i>0;i--){
if((d-i+1)==e)printf("Цифра %d\n",c[i]); //Вывод искомой цифры
}
return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота