Мозговина12
01.07.2020 14:38

Дано натуральное число n( трехзначное ) составить программу которая вычисляет сумму цифр этого числа

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
dyba00ozclh4
29.07.2020 11:49
Код на Паскале:
Program proba;
Uses crt;
Var n,s:integer;
Begin
writeln('введите натуральное число');
Readln(n);
s:=0;
repeat s:=s+n mod 10;  
 n:=n div 10;until n=0;
writeln('сумма цифр ',s);
end.
P.S. Программа вычисляет не только трехзначные числа ;)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота