ISMAL2009
22.05.2023 00:57

Составить массиве хранится информация о среднедневной температуре декабря. составьте программу, которая подсчитает, сколько в декабре было дней с нулевой, отрицательной и положительной температурой

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
DRUGAЯ
06.06.2020 21:29

program xxx;

   var i, m, p, n : integer;

         t : array[1..31] of real;

begin

  writeln('введите температуру ')

  for i:=1 to 31 do

     readln(t[i]);

  m:=0; p:=0; n:=0;

  for i:=1 to 31 do

    begin

       if t[i]<0 then m:=m+1;

       if t[i]>0 then p:=p+1;

       if t[i]=0 then n:=n+1

    end;

  writeln('Дней с отрицательной температурой было - ', m);

  writeln('Дней с положительной температурой было - ', р);

  writeln('Дней с нулевой температурой было - ', n);

  readln

end.

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота