baxrom2
09.11.2022 07:19

Dev_c++ напишите программу, которая вводит координаты двух точек на числовой оси и выводит расстояние между ними.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Амишка51
28.07.2020 20:25
#include <iostream>                
#include <math.h>;               

using namespace std;               
int main(int argc, char* argv[])               
{               
    setlocale(LC_ALL, "Russian");
       double x1,x2,y1,y2,distance;             
 
        cout <<"Введите координату x1:";            
        cin>>x1;                    
        cout <<"Введите координату y1:";            
        cin>>y1;            
        cout <<"Введите координату x2:";            
        cin>>x2;            
        cout <<"Введите координату y2:";            
        cin>>y2;                             
        distance=sqrt(pow((x2-x1),2)+pow((y2-y1),2));      // формула для вычисления расстояния
        cout<<"Расстояние между двумя точками:"<<distance<<endl; 
        system("pause");
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота