kaluznavikusa9
24.01.2023 06:53

Пусть дано некоторое целое число. требуется составить программу, которая выводит на экран монитора сообщение о том, какое это число: положительное либо отрицательное. и если это число положительное, уменьшает его в 2 раза, в противном случае возводит его в квадрат.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nekit120
28.07.2020 10:57
Program a2;
var a,b:integer;
begin
 write('Введите целое числo');
 readln(a);
  if a > 0 then  begin
 b:=a div 2;                                   
  end
  else
 begin b:=a*a;
                 end;
  write ('b',b);
 end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота