Напишите программу в паскаль abc, которая позволяют записать логические выражения, которые имеют значение «истина» когда: а) каждое из чисел a и b больше 100; б) только одно из чисел a и b четное; в) хотя бы одно из чисел a и b положительное.
Var a,b:real; l,f,j:boolean; begin f:=false; read (a,b); if (a > 100) and (b > 100) then l:=true else l:=false; if ((a mod 2)=0) then f:=true; if ((b mod 2)=0) then f:=true; if ((a mod 2)=0) and ((b mod 2)=0) then f:=false if a > 0 or b > 0 then j:=true else j:=false; writeln ("а) ",l); writeln ("б) ",f); writeln ("в) ",j); end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку