РенатаG
19.05.2023 18:11

Вклассе 20 учеников писали диктант по языку. напишите программу, подсчитывающую количество двоек, троек, четвёрок и пятёрок, полученных за диктант. надо написать программу на posal abc

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ryabchenko20021
28.07.2020 10:18
Var a,n,l,o2,o3,o4,o5:integer;
begin
n:=20;
a:=0;
o2:=0;
o3:=0;
o4:=0;
o5:=0;
repeat
a:=a+1;
write('Введите оценку ', a, ' ученика: ');
read(l);
if l = 2 then o2:=o2+1;
if l = 3 then o3:=o3+1;
if l = 4 then o4:=o4+1;
if l = 5 then o5:=o5+1;
until a=n;
writeln('В классе: ', o2, ' Двоек, ', o3, ' Троек, ', o4, ' Четвёрок, ', o5, ' Пятёрок.')
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота