Nemogu999
01.04.2023 22:14

паскаль 8 класс! напишите программу, которая строит таблицу истинности для логической формулы (not a)or(not b)or c. подумайте сколько вложенных циклов вам понадобиться.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Рафаэлла2004
02.10.2020 19:56
Uses Crt;
var
  a,b,c:boolean;
begin
  ClrScr;
  for a:=False to True do
  for b:=False to True do
  for c:=False to True do
  Writeln(a:6,b:6,c:6,(not a) or (not b) or c:6);
  ReadKey
end.

Результат выполнения программы:
 FALSE FALSE FALSE  TRUE
 FALSE FALSE  TRUE  TRUE
 FALSE  TRUE FALSE  TRUE
 FALSE  TRUE  TRUE  TRUE
  TRUE FALSE FALSE  TRUE
  TRUE FALSE  TRUE  TRUE
  TRUE  TRUE FALSE FALSE
  TRUE  TRUE  TRUE  TRUE
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота