nataliyapotehi
13.12.2022 00:53

Дан массив из 20 действительных чисел. напишите программу, которая складывает отдельно все положительные элементы этого массива, а отдельно отрицательные элементы и выдает на экран полученные результаты. желательно подробную программу, буду всем )

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nastuaserova
27.07.2020 22:17
Var A:array[1..20]of real;
B,C:real;
i:byte;
Begin
WriteLn('Введи элементы массива через пробел');
For i:= 1 to 20 do
 Read(A[i]);
For i:= 1 to 20 do
 if A[i]>0 then B:=B+A[i]
 else C:=C+A[i];
WriteLn('Сумма положительных элементов = ',B);
WriteLn('Сумма отрицательных = ',C)
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота