настя7322
03.04.2021 21:10

Написать программу на яп паскаль: из чисел от 10 до 99 вывести те, сумма цифр которых равна s ( чтобы в программе были формулы по нахождению p1 и p2 и чтобы программа была выполнена через операторы div и mod,желательно с объяснением

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
даша3634
26.05.2020 10:50

var k,s, p1, p2 : integer;

begin

write('s = ');

readln(s);

for k:= 10 to 99 do

begin

p1:= k div 10;

p2:= k mod 10;

if p1+p2=s then writeln (k);

end;

end.

Пример:

s = 12

39

48

57

66

75

84

93

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота