negricho
27.09.2022 20:56

Напишите программу: даны два массива a и b, каждый из которых состоит из 13 элементов; массивы взяты в диапазоне от -50 до 50; элементы вводятся случайным образом(randomize); найти минимальный и максимальный элементы в каждом из массивов; затем первый массив упорядочить по возрастанию, а второй- по убыванию; затем вывести это всё на экран; ! pascal!

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Vasiuk1055
09.06.2023 04:34

Другой перевода из десятичной системы в двоичную: берем число и делим его столбиком на основание системы, в которую переводим. Нацело. Если есть остаток, то его оставляем. А получившееся часное снова делим на основание требуемой системы. И так далее, пока часное не перестанет делится нацело. А чтобы записать число в требуемой системе, записываем последнее часное, а потом все остатки, начиная с последнего. (кстати, по аналогии можно переводить в любую другую систему).

 

173|   2

172   86|  2

   1   86   43|  2

          0   42   21|  2

                1   20   10|  2

                       1   10   5|  2

                             0    4   2|  2

                                   1   2   1

                                        0

 

173_{10} = 10101101_2

 

Итого: в записи 5 единиц.

0,0(0 оценок)
Ответ:
NastiaKostiuk
25.04.2021 04:28

var
    m : array [1..10] of Integer;
    i, b, s, p : Integer;
begin

 

   Writeln('Введите массив:');

   for i := 1 to 10 do

   begin
      Write(i, ': ');

      Readln(m[i]);

    end;

 

   s := 0;
   b := m[1];
   p := 1;

   for i := 1 to 10 do
   begin
      if b < m[i] then b := m[i];
      if m[i] > 0 then s := s + m[i];
      if m[i] mod 2 = 0 then p := p * m[i];
   end;

   Writeln('Наибольший элемент = ', b);
   Writeln('Сумма неотрицаельных элементов = ', s);
   Writeln('Произведение четных элементов = ', p);

   ReadLn;
end.

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота