1ТекуОтОтветов
11.12.2021 21:11

Составьте программу, которая определяет, является ли данное натуральное число простым, и выводит на экран соответствующее сообщение: «да» либо «нет».

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
gusarova17
06.06.2020 21:21

program xxx;

var k, d, n : integer;

      pr : boolean;

begin

  writeln('Введите число k=');

  readln(k);

  d:=2;

  n:= k div 2;

  pr:=false;

  while (d<=n) and not(pr) do

     if k mod d = o then pr:=true else d:=d+1;

  if pr then writeln (k, '- нет, число не простое') else writeln (k, ' да,число простое');

   readln

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота