ExKise
17.09.2021 17:54

Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения. учтите, что числа могут быть отрицательными (паскаль авс)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
jhgdfkjg
27.07.2020 16:26
UPD

Var
a,b,s,i:integer;
begin
readln(a,b);
if a <> b then
for i:=1 to abs(b) do s:=s+a
else for I:=1 to abs(b) do s:=s+a;
if (a<0) and (b<0) then s:=abs(s)
else if b<0 then s:=-s;
writeln(s);
end.
0,0(0 оценок)
Ответ:
Kristina2003star1
27.07.2020 16:26
Var A,B,i,S:integer;
Ch:Char;
Begin
S:=0;
Write('A = ');ReadLn(A);
Write('B = ');ReadLn(B);
if ((A<0)and(B>0))or((A>0)and(B<0)) then Ch:='-';
A:=Abs(A);
B:=Abs(B);
For i:= 1 to A do
 S:=S+B;
WriteLn(Ch,S)
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота