saigafarovatn
18.01.2023 20:36

Составьте программу, которая считает в формуле, заданной с клавиатуры, количество плюсов и минусов. на паскале. p.s формулы в программе быть не должно

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Мальвина1122
26.05.2020 09:54

var a:string;
i:integer;
c:boolean;
begin
readln(a);
repeat
if pos('+',a)<>0 then begin inc(i); delete(a,pos('+',a),1); end;
if pos('-',a)<>0 then begin inc(i); delete(a,pos('-',a),1); end;
if (pos('+',a)=0) and (pos('-',a)=0) then c:=true;
until c;
writeln(i);
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота