dimasik337
04.06.2022 21:31

Напишите программу, которая размещает случайным образом две ладьи на шахматной доске и определяет, бьют ли эти ладьи друг друга.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
cksenia112
26.05.2020 09:45

Язык СИ:

#include<stdio.h>

#include<stdlib.h>

#include<float.h>

#include<time.h>

int main(){

   

   srand(time(0));

   const long double cbc=64.0L-FLT_EPSILON;

   unsigned short int r1=cbc/RAND_MAX*rand(),

                                  r2=cbc/RAND_MAX*rand();

   

   printf("R1: %c%c\n",65+r1%8,49+r1/8);

   printf("R2: %c%c\n",65+r2%8,49+r2/8);

   printf("%s\n",r1%8==r2%8 || r1/8==r2/8?"yes":"no");

   

   return 0;

   

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота