Sweetdreams2003
13.02.2020 15:18

1.составить программу для определения принадлежности точки заданной области pascal 2. сгенерировать элементы массива целого типа случайным образом в заданном диапазоне [a,b] согласно варианту a= -22 b=132 найти среди элементов массива минимальный элемент.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
inkara8
13.12.2020 12:28

using System;

internal class Program {

   private static void Main() {

       Console.WriteLine("Введите минимум для счетчика");

       var min = int.Parse(Console.ReadLine() ?? throw new ());

       Console.WriteLine("Введите максимум для счетчика");

       var max = int.Parse(Console.ReadLine() ?? throw new ());

       Console.WriteLine("Введите значение для счетчика");

       var v = int.Parse(Console.ReadLine() ?? throw new ());

       var counter = new Counter(max, min, v);

       Console.WriteLine("Введите + для увеличение и - для уменьшения, иное для выхода");

       do {

           var c = Console.ReadKey();

           if (c.KeyChar == '+') counter.Increase();

           else if (c.KeyChar == '-') counter.Decrease();

           else break;

           Console.WriteLine($" => {counter.Value}");

       } while (true);

       Console.ReadKey();

   }

}

public class Counter {

   public readonly int Maximum;

   public readonly int Minimum;

   public int Value { private set; get; }

   public Counter(int maximum, int minimum, int counter) {

       this.Maximum = maximum;

       this.Minimum = minimum;

       counter = Math.Min(this.Maximum, counter);

       counter = Math.Max(this.Minimum, counter);

       this.Value = counter;

   }

   private Counter() {

       this.Maximum = 10;

       this.Minimum = 0;

       this.Value = 5;

   }

   public void Increase() {

       var value = this.Value + 1;

       if (value > this.Maximum || value < this.Minimum)

           return;

       this.Value++;

   }

   public void Decrease() {

       var value = this.Value - 1;

       if (value > this.Maximum || value < this.Minimum)

           return;

       this.Value--;

   }

}

0,0(0 оценок)
Ответ:
jjjonh9746
13.02.2021 17:22

ответ: Тут в задание опечатка скорее всего

Если делать по примеру из задания, будет такой код:

for i in range(20):

   n = i

   n = bin(n)[2:]

   sum = 0

   if int(n) % 2 == 0:

       sum = str(n).count('1')

       sum = bin(sum)[2:]

       r = n + sum

   else:

       r = '11' + n + '00'

   r = int(r, 2)

   if r > 215:

       print(i)

Если делать по условию задание, будет такой код:

for i in range(30):

   n = i

   n = bin(n)[2:]

   sum = 0

   if int(n) % 2 == 0:

       sum = str(n).count('1')

       sum = bin(sum)[2:]

       r = n + sum

   else:

       r = '1' + n + '00'

   r = int(r, 2)

   if r > 215:

       print(i)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота