otepovaaazan
21.08.2022 09:48

Abc pascal 1) составьте программу расположения элементов в массиве a(n) в порядке убывания. 2) составьте программу перемены местами в массиве b(n) второго и предпоследнего элементов. 3) составьте программу удаления пятого элемента массива c(n).

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
konstantin1959
02.10.2020 18:53
1)cсортировка методом пузырька 
const n=10;
var    a: array[1..n] of integer;  
  i, j, k: integer; 
begin  
  randomize;   
  write ('Исходный массив: ');  
  for i := 1 to n do begin  
      a[i] := random(256);     
   write (a[i]:4);    end;    
writeln; writeln;    
  for i := 1 to n-1 do   
     for j := 1 to n-i do   
         if a[j] < a[j+1] then begin     
           k := a[j];            
    a[j] := a[j+1];        
        a[j+1] := k        
    end;    
 write ('массив по возрастанию: '); 
   for i := 1 to n do  
     write(а[i]:4);   
  writeln;
 readln;
end.


2)
const    n = 10;
 var    b: array[1..n] of integer; 
   i, j, x: integer; 
begin   
 randomize;  
   write ('Исходный массив: ');  
  for i := 1 to n do begin  
      b[i] := random(256);    
    write (b[i]:4);  
  end;  
  writeln; 
writeln;  
x:=b[2];
b[2]:=b[n-1];
b[n-1]:=x;   
  write ('массив  ');  
  for i := 1 to n do      
  write (b[i]:4);   
  writeln; 
readln
end.


3)
const    n = 10; 
var    c: array[1..n] of integer;  
  i, j, x: integer; 
begin   
 randomize; 
    write ('Исходный массив: ');   
 for i := 1 to n do
 begin     
   c[i] := random(256);     
   write (c[i]:4);   
 end;    
writeln; writeln;  
writeln; 
for i:=5 to n-1 do
c[i]:=c[i+1];

    write ('массив  '); 
   for i := 1 to n-1 do   
     write (c[i]:4);  
   writeln; 
readln;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота