Составить программу, заполняющую массив десятью случайными числами и выводящую на экран: 1) максимальное значение; 2)минимальное значение; 3)среднее арифметическое значение.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Анастасия0000000000
23.05.2020 17:52

program n1;
  const n=10;
  var
  mas:array[1..n] of integer;
  i:integer;
  max,min,sum:integer;
  ar:real;
  begin
   for i:=1 to n do

begin
  mas[i]:= random (20)-10;
  write(mas[i],' ');
  writeln
 
end;

  max:=1;
   for i:=2 to n do

   if mas[i]>mas[max] then
   max:=i;
   writeln;
   writeln('Максимаьное значение a[',max,']= ',mas[max]);

   
  min:=1;
  for i:=2 to n do
   if mas[i]<mas[min] then
   min:=i;
   writeln;
   writeln(Минимальное значение a[',min,']= ',mas[min]);
   
 for i:=1 to n do
   sum:=sum+mas[i];
    ar:=sum/n;
   writeln;
   writeln('Среднее арифметическое =  ',ar);
   
end.
{Немного нерационально но работает=)}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота