People100
08.11.2021 22:04

Определите, каких чисел в массиве больше: которые делятся на первый элемент массива или которые делятся на последний элемент массива. программа c++, составить проект.​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
vanschool
27.01.2024 21:52
Конечно, я могу помочь вам с этим вопросом!

Для начала, мы должны написать программу на языке C++, которая будет решать данную задачу. Вот как выглядит код программы:

```cpp
#include

int main()
{
const int size = 10; // размер массива
int arr[size]; // объявление массива
int firstElement, lastElement; // переменные для хранения первого и последнего элементов массива
int countFirstDivisible = 0; // счетчик чисел, делящихся на первый элемент массива
int countLastDivisible = 0; // счетчик чисел, делящихся на последний элемент массива

// Заполняем массив с помощью пользовательского ввода
std::cout << "Введите элементы массива: ";
for (int i = 0; i < size; i++)
{
std::cin >> arr[i];

// Присваиваем значения первого и последнего элемента массива
if (i == 0)
firstElement = arr[i];
else if (i == size - 1)
lastElement = arr[i];
}

// Подсчитываем количество чисел, делящихся на первый и последний элементы массива
for (int i = 0; i < size; i++)
{
if (arr[i] % firstElement == 0)
countFirstDivisible++;
if (arr[i] % lastElement == 0)
countLastDivisible++;
}

// Определяем, каких чисел больше и выводим результат
if (countFirstDivisible > countLastDivisible)
std::cout << "Чисел, делящихся на первый элемент больше." << std::endl;
else if (countLastDivisible > countFirstDivisible)
std::cout << "Чисел, делящихся на последний элемент больше." << std::endl;
else
std::cout << "Чисел, делящихся на первый и последний элементы одинаковое количество." << std::endl;

return 0;
}
```

Давайте разберем подробно эту программу:
1. Мы объявили необходимые переменные для хранения массива, первого и последнего элементов, а также счетчиков чисел, делящихся на эти элементы.
2. Затем мы запрашиваем у пользователя ввод элементов массива с помощью цикла `for` и сохраняем первый и последний элементы массива в отдельные переменные.
3. Затем мы считаем количество чисел в массиве, которые делятся на первый и последний элементы, с помощью второго цикла `for`.
4. После этого мы сравниваем количество чисел, делящихся на первый и последний элементы, и выводим соответствующий результат.

Таким образом, программа подсчитывает количество чисел, делящихся на первый и последний элементы массива, и выводит то, каких чисел больше.

Надеюсь, этот ответ был понятен и информативен для вас! Если у вас возникнут еще вопросы, не стесняйтесь задавать. Я всегда готов помочь!
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота