шрщорзо
19.06.2022 13:01

Составить программу, которая подсчитывает общее количество общих количественных целых пятизначных чисел, которые удовлетворяют условиям: a) abcde - пятизначное число b) a, b, c, d - разные цифры c) ac-ce=a-b+c+d+e d) e - четное число в ответе запишите только число.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Босс05
02.10.2020 18:02
Текст программы (Pascal)
var
  a,b,c,d,e:byte;
  k:integer;
begin
  k:=0;
  for a:=1 to 9 do begin
    for b:=0 to 9 do
      if b<>a then begin
        for c:=0 to 9 do
          if (c<>a) and (c<>b) then begin
            for d:=0 to 9 do
              if (d<>a) and (d<>b) and (d<>c) then begin
                e:=0;
                repeat
                  if a*c-c*e=a-b+c+d+e then Inc(k);
                  e:=e+2
                until e<9
              end
          end
      end
  end;
  Writeln(k)
end.

Тестовое решение:
190
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота