камидь
22.03.2022 16:58

Составить программу на языке паскаль для вычисления и печати таблицы значений функции y=sin2(x-1)+2cos((x-1)/2), при условии, что x0=0.3, xк=1.7, dx=0.2.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Чика1без2ника
26.07.2020 08:59
// PascalABC.Net v2.2 build 1019
program znanija_12709887;

const  
  xMin = 0.3; 
  xMax = 1.7;   
  xStep = 0.2;
var  
  y : real; 
  x : real;
begin 
  x := xMin; 
  while x <= xMax do begin   
    y := sin(2)*(x - 1) + 2 * cos((x - 1) / 2);   
    writeln ('x = ' , x, ' y = ', y);   
    x := x + xStep; 
  end;  
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота