kcasimova2018
10.04.2023 06:52

Написать программу решения следующей : дан массив из 20 целых чисел. 1. найти среднее арифметическое элементов массива. 2. найти количество чисел в заданном массиве, отличных от его последнего числа. 3. найти произведение отрицательных чисел массива.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nikitanosach2901
26.07.2020 01:06
Var a:array [1..20] of integer;
i,p:integer;
n:real;
m:longint;
begin
n:=0;
p:=0;
m:=1;
write ('Массив: ');
for i:=1 to 20 do
begin
a[i]:=random(101)-50;
write (a[i],' ');
end;
for i:=1 to 20 do
begin
n:=n+a[i];
end;
n:=n/20;
writeln;
writeln;
write ('Среднее арифметическое = ',n);
for i:=1 to 19 do
begin
if a[20]<>a[i] then p:=p+1;
end;
writeln;
write ('Кол-во чисел отличных от последнего в массиве = ',p);
for i:=1 to 20 do
begin
if a[i]<0 then m:=m*a[i];
end;
writeln;
write ('Произведение отрицательных чисел массива = ',m);
end.

Написать программу решения следующей : дан массив из 20 целых чисел. 1. найти среднее арифметическое
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота