matveykatvey13
23.02.2022 14:58

Составьте программу которая заполняет массив а [1..20] случайными целыми числами в диапазоне от 1 до 10 и находит среднее арифметическое элементов с четными значениями и нечётными индексами

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
annakraevaya061
26.05.2020 07:18

var a:array[1..20] of integer; i,arf,k:integer;

begin
k:=0;
for i:=1 to 20 do
begin
a[i]:=random(10);
if (a[i]/2=a[i] div 2) or (i/2<>i div 2) then
begin arf:=arf+a[i]; inc(k); end;
end;
arf:=round(arf/k);
for i:=1 to 20 do writeln('a[',i,']= ',a[i]);
writeln('Srendee arirfm. chentix chisel u nechetnix indexov = ',arf);
readln;
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота