krikstoon1
01.03.2023 03:12

Нужно составить программу в бейсик. по теме «составление программ линейных алгоритмов». три сопротивления r1, r2, r3 соединены последовательно. найти сопротивление соединения.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
user666triplesix
19.04.2020 00:51

Вот тебе в паскале


program ryad_chisel;

var N, t:integer;

begin

read(N);

t:=(N*(N+1))div 2;

if t mod 2 =1 then writeln('IMPOSSIBLE')

else begin

     if N mod 2 =0 then begin

                        t:=N div 4;

                        repeat

                        write('+');

                        t:=t-1;

                        until t=0;

                        t:=N div 2;

                        repeat

                        write('-');

                        t:=t-1;

                        until t=0;

                        t:=N div 4;

                        repeat

                        write('+');

                        t:=t-1;

                        until t=0;

                        end

     else begin

          t:=((N+1) div 4)-1;

          repeat

          write('+');

          t:=t-1;

          until t=0;

          t:=((N-1) div 2)+1;

          repeat

          write('-');

          t:=t-1;

          until t=0;

          t:=(N+1) div 4;

          repeat

          write('+');

          t:=t-1;

          until t=0;

          end

     end    

end.

0,0(0 оценок)
Ответ:
Fluttershy22102005
01.06.2021 12:46
{
Если что, часть программы не нужна для построения цепочки. Она просто иллюстрирует, что полученный результат верен.
}

var
 sq : array[0..999] of array[0..9] of boolean;
 co : array[0..999] of integer;
 ar : array[1..10003] of 0..9;
  i,j: integer;
 x: integer;
 t : boolean;
 begin
 for i := 0 to 999 do
   begin
   for j := 0 to 9 do
   sq[i][j] := false;
   co[i] := 0;
   end;
 for i := 1 to 3 do
   ar[i] := 0;
 i := 3;
 t := true;
 {write('000');}
 while t do
   begin
   i := i + 1;
   x := ar[i-3]*100 + ar[i-2]*10 + ar[i-1];
   if co[x] >= 10 then t := false
     else
     begin
     j := 1;
     while sq[x][j] do 
       j := (j + 1) mod 10;
     ar[i] := j;
     sq[x][j] := true;
     co[x] := co[x] + 1;
     {write(j)}
     end;
   end;
 {writeln;}
 writeln('Length: ',i - 1);

 {просто чтобы убедиться}
 for i := 0 to 999 do
   for j := 0 to 9 do
   sq[i][j] := false;

  t := true;
 j := 0;
 i := 1;
 while (i <= 10000) and t do
   begin
   x := ar[i] * 100 + ar[i+1] * 10 + ar[i+2];
   if sq[x][ar[i+3]] then t := false
     else
     begin
     sq[x][ar[i+3]] := true;
     j := j + 1;
     end;
   i := i + 1
   end;
 if t and (j = 10000) then
   write('Confirmed')
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота