Сэээээ
09.07.2020 01:44

Составить программу для вычисления суммы натуральных чисел которые делятся нацело на 7 для массива от 1 до 100

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
34224253
24.07.2020 21:11
Program mew;
var a: array [1..100] of integer;
sum,i: integer;
begin
sum:=0;
for i:=1 to 100 do
begin
a[i]:=random(100);
if (a[i] <> 0) and (a[i] mod 7 = 0)  then
begin
write(a[i], ' ');
sum:=sum+a[i];
end;
end;
writeln('Сумма равна',' ', sum);
end.
0,0(0 оценок)
Ответ:
MaximRomanenko
24.07.2020 21:11
Var a:array[1..100] of integer;
i,s:integer;

begin
write ('vvardite  massiv=');
for i:= 1 to 100 do
readln(a[i]);
s:=0;
for i:= 1 to n do 
if (a[i]>0) and (a[i] mod 7 =0) then s:=s+a[i];
writeln(' summa cisel deliscihsia na 7'=,s);
readln;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота