Нарисовать блок схему и составить программу , которая 1) вводит массив из 10 чисел 2)выбирает в этом массиве числа большие -3.5 и находит из них наименьшее 3) значение наименьшего вывести на печать -100 , -50 , -30 , -3.7 , -3 , 0 , 2 , 3 ,20, 500.
Const n=10; var a:array[1..n] of real; i:integer; amin:real; begin Writeln('Введите элементы массива'); amin:=100; for i:=1 to n do begin Read(a[i]); if a[i]>-3.5 then if amin>a[i] then amin:=a[i] end; Writeln('Минимальный среди элементов, больших -3.5: ',amin:0:3) end.
Тестовое решение: Введите элементы массива -100 -50 -30 -3.7 -3 0 2 3 20 500 Минимальный среди элементов, больших -3.5: -3.000
Блок-схема во вложении
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку