pip2281
28.09.2020 08:10

Найти среднее арифметическое элементов одномерного массива а10. составить программу.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ЕнотОбормот
26.05.2020 06:57

Допустим, что все элементы должны быть положительными.

 

#include <iostream>
using std::cout;
using std::cin;
using std::endl;

int main()
{
   int a[10] = { 5, 2, 8, 21, 17, 9, 0, 3, 1, 2 };
   float mean = 0;

   for(int i = 0; i < 10; i++)
   {
      cout << a[i] << ' ';

      mean += a[i]; //Найти сумму всех элементов
   }

   mean /= 10;

   cout << "\nArithmetic mean = " << mean << endl;

   return 0;
}


Найти среднее арифметическое элементов одномерного массива а10. составить программу.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота