46. составить программу, которая проверяла бы, не приводит ли суммирование двух целых чисел а и в к переполнению (т.е. к результату большему чем 32 767). если будет переполнение, то сообщить об этом, иначе вывести сумму этих чисел. через дельфи
Program Name; uses crt; Var a, b, s :integer; Begin Write('введите a '); readln(a); Write('введите b '); readln(b); S:=a+b; if s<32767 then writeln(s) else writeln('произошло переполнение'); End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку