evakuleva
30.10.2021 15:03

Как составить программу для решения алгоритма: дан массив а(n,n). нужно поменять местами элементы к- и j- строки этого массива

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Карисёнок
24.07.2020 15:59
Const
n=10;
var
i,j,k,m,buf:integer;
a:array[1..n,1..n]of integer;
begin
    for i:=1 to n do
        begin
            writeln;
               for m:=1 to n do
                   begin
                       a[i,m]:=random(20);
                       write(a[i,m]:4);
                    end;
        end;
writeln;
writeln('k,j ?');
readln(k,j);
   for m:=1 to n do
      begin
          buf:=a[k,m];
          a[k,m]:=a[j,m];
          a[j,m]:=buf;
       end;
for i:=1 to n do
   begin
       writeln;
          for m:=1 to n do
              write(a[i,m]:4);
    end;
end.
                
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота