yanastepina83
26.03.2022 06:09

Составьте программу, проверяющую есть ли в двумерном массиве a (n,n) столбцы, все элементы которых различны.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kebabchik111
24.07.2020 14:59
                      Const n=4;
Var x:array [1..n,1..n] of integer;
k,s,i,j:integer;
begin  
 randomize;   
 for i:=1 to n do begin      
  for j:=1 to n do begin     
       x[i,j] := random(100);      
      write(x[i,j]:6);   
     end;      
  writeln; 
   end; 
  for i := 1 to n do
    for j := 1 to n do   
   for k := j+1 to n do    
    if x[j,i]=x[k,i]
then 
writeln('NO') 
else 
writeln ('YES');
readln;
end.       
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота