нешарю8
14.12.2020 01:20

Сделать= а) написать программу, определяющую среднее арифметическое всех чисел от 0 до заданного пользователем. б)написать программу, определяющую количество четных чисел от 0 до заданного пользователем числа.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
snakesap
26.05.2020 06:38

#include <iostream>
using std::cout;
using std::cin;
using std::endl;

int main()
{
   int number, counter = 0;
   float average = 0;

   cout << "Enter the number: ";
   cin >> number;

   //1)
   for(int i = 0; i <= number; i++)
   {
      average += i;
   }
   average /= (number + 1);

   //2)
   for(int i = 0; i <= number; i++)
   {
      if(i % 2 == 0) //Если чётное
      {
         counter++;
      }
   }

   cout << "Average = " << average << endl;
   cout << "The amount of even elements: " << counter << endl;

   return 0;
}


Сделать= а) написать программу, определяющую среднее арифметическое всех чисел от 0 до заданного пол
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота