Анюта3Б
06.08.2020 07:11

Составьте программу для вычисления площади прямоугольника и площади круга, если r=45, a=23, b=17​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Lesa222
05.01.2020 22:46
// PascalABC.NET 3.0, сборка 1088
const
  nn=100;
var
  a:array[1..nn] of integer;
  i,n,k,max,f2,f1,fib:integer;
begin
  Write('Введите количество элементов в массиве (1-100): ');
  Read(n);
  Randomize;
  Writeln('*** Сформированный массив ***');
  max:=0;
  for i:=1 to n do begin
    a[i]:=Random(100)+1;
    Write(a[i],' ');
    if max<a[i] then max:=a[i]
    end;
  Writeln;
  // Заменяем элементы, равные числам Фибоначчи, на -1
  k:=0;
  f1:=1; fib:=1;
  while fib<=max do begin
    for i:=1 to n do
      if a[i]=fib then begin a[i]:=-1; Inc(k) end;
    f2:=f1; f1:=fib; fib:=f1+f2
    end;
  if k>0 then begin
    // Удаляем элементы, равные -1
    Writeln('*** Результирующий массив ***');
    for i:=n downto 1 do begin
      if a[i]=-1 then begin
        if i<>n then
          for k:=i to n-1 do a[k]:=a[k+1];
        Dec(n);
        end;
      end;
    for i:=1 to n do Write(a[i],' ');
    Writeln
    end
  else Writeln('Числа Фибоначчи не обнаружены')
end.
   
Тестовое решение:
Введите количество элементов в массиве (1-100): 20
*** Сформированный массив ***
21 51 15 38 52 35 42 51 16 53 96 3 53 82 87 12 55 37 93 19
*** Результирующий массив ***
51 15 38 52 35 42 51 16 53 96 53 82 87 12 37 93 19
0,0(0 оценок)
Ответ:
nike1110
11.09.2022 19:14

использовать Чертежник

алг

нач

опустить перо

сместиться в точку (0,4)

сместиться в точку (1.5,4)

сместиться в точку (2,3.5)

сместиться в точку (2,2.5)

сместиться в точку (1.5,2)

сместиться в точку (0,2)

сместиться в точку (1.5,2)

сместиться в точку (2,1.5)

сместиться в точку (2,0.5)

сместиться в точку (1.5,0)

сместиться в точку (0,0)

поднять перо

сместиться в точку (3,0)

опустить перо

сместиться в точку (4,4)

сместиться в точку (5,0)

поднять перо

сместиться в точку (3,1.5)

опустить перо

сместиться в точку (5,1.5)

поднять перо

сместиться в точку (6.3,0)

опустить перо

сместиться в точку (7,4)

сместиться в точку (7.7,0)

сместиться в точку (8,0)

сместиться в точку (8,-1)

сместиться в точку (8,0)

сместиться в точку (6,0)

сместиться в точку (6,-1)

поднять перо

сместиться в точку (9,4)

опустить перо

сместиться в точку (9,0)

сместиться в точку (11,4)

сместиться в точку (11,0)

поднять перо

сместиться в точку (12,0)

опустить перо

сместиться в точку (12,4)

сместиться в точку (13,1.5)

сместиться в точку (14,4)

сместиться в точку (14,0)

поднять перо

сместиться в точку (-5,-5)

кон

Объяснение:


надо нарисовать имя Вадим в программе кумир стандарт ​
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота