dawlatowaalbina
12.04.2023 13:18

Склавиатуры вводят слово и символ. составьте программу, которая определяет позицию заданного символа.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
is835172Alexandr
23.05.2020 17:48

program xxx;

var a,s : string;

   i:integer;

begin

   writeln ('Введите слово и символ-');

   readln (s,a);

   for i:=1 to length(a) do

     if copy (s,i,1)=a then writeln (i);

   readln

end.

 

0,0(0 оценок)
Ответ:
123456782121
23.05.2020 17:48

паскаль:

 

uses crt;

var a,b:string;\ а-слово ,b-символ

i:integer;\ переменная для счета

begin

writeln ('Слово и символ');

readln (a,b);\\ввод данных

 

for i:=1to length(a) do if copy (a,i,1)=b then writeln (i);\\Копирование по порядку символов слова а  и сравнение каждого с символом b. Вывод ответа. Или ответов 

readkey;\\если символы в слове повторяются

end.

 

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота