sweetmalboro
31.10.2020 17:15

Составить программу перевода строки, представляющей собой запись целого положительного числа, в соответствующую величину целого типа (не используя процедуру val) си​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
infourazyukp092y0
26.01.2023 12:18
Да без проблем!

gcd(77164189341682084692124351766096496451364840671846455244761, 46668734283684548617206823665104829826096872771679324943689);

448643232670469

a:=ifactor(77164189341682084692124351766096496451364840671846455244761);

   4                                                            
(3)  (11) (503) (809) (573384723060967) (448643232670469) (492166512383869) (1680979)

b:=ifactor(46668734283684548617206823665104829826096872771679324943689);
(781199815286623) (283598494080047) (448643232670469) (39869)
(11776697129)

Вычислите наибольший общий делитель чисел 7716418934168208469212435176609649645136484067184645524476
0,0(0 оценок)
Ответ:
beka9867
15.08.2021 07:34
Язык не указан, Default-Language это C. На нём и напишу.
1.
#include <stdio.h>
int main() {
    int n;
    scanf("%d", &n);
    if (n % 10 == 4 || n % 10 == 7 || n / 10 == 4 || n / 10 == 7)
        printf("YES\n");
    else
        printf("NO\n");
    return 0;
}
Для порядку скажу что на Perl это можно реализовать проще.
#!perl
%h { 4 => 0, 7 => 0};
<>;
if (exists $h{$_%10} || exists $h{$_/10}) {
    print "YES\n";
else {
    print "NO\n";
}
Но мы ушли от темы. Итак, 2. Тут всё ещё проще:
#include <stdio.h>
int main() {
    int n;
    scanf("%d", &n);
    if (!(n % 3))
        printf("Multiple of 3\n");
    else
        printf("Not multiple of 3\n");
    if (n % 10 == 3)
        printf("Ends by 3\n");
    else
        printf("Not ends by 3\n");
    return 0;
}
Тут более простой реализации на другом известном мне языке нету, так что приводить дополнительно ничего не буду.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота