lera784738374
09.04.2021 00:04

Написать программу для нахождения произведения двух целых чисел х и у без использования операции умножения. паскаль

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
асаль14
02.10.2020 15:57
Program a1;
var x,y,s: integer;
begin
read (x,y);  
write(x,'*',y,'=');  
while x>0 do 
 begin 
    If ((x mod 2) <>0) then s:=s+y; 
    x:= x div 2;  
   y:=y+y;
 end;
write(s);
writeln();
readln();
end.
Русский умножения
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота