isaevas153Sasha
04.02.2020 02:22

Выручайте, написать программу в паскале: " даны два целых числа: d (день) и m (месяц), определяющие правильную дату не високосного года. вывести значения d и m для даты, предшествующей указанной." используя команду case.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Валерия3445
23.07.2020 16:32
Program a;
var D,M: integer;
begin 
readln (D,M); //DD MM
if (D<>1) then Writeln (D-1,' ',M) 
else
case M of
01 : Writeln('31 12');
02 : Writeln('31 01');
03 : Writeln('28 02');
04 : Writeln('31 03');
05 : Writeln('30 04');
06 : Writeln('31 05');
07 : Writeln('30 06');
08 : Writeln('31 07');
09 : Writeln('31 08');
10 : Writeln('30 09');
11 : Writeln('31 10');
12 : Writeln('30 11');
end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота