dazacyhko
13.10.2021 03:37

(паскаль или delphi) написать программу поиска двухзначных чисел, удовлетворяющих следующему условию: если к сумме цифр числа прибавить квадрат этой суммы, то получится само число.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
master204
23.07.2020 16:22
Program z_3;
var a,b,n,s, i: integer;
Begin 
repeat  
writeln ('Введите Ваше число'); 
readln (n); 
if (n < 10) or (n > 99) then i:= 0 
else i:= 1; 
until i>0; 
a:= n mod 100 div 10; 
b:= n mod 10; 
s:= (a+b)+sqr (a+b); 
if s <> n then writeln ('Число не соотвествует условию') 
else writeln ('Число ',s, ' соответствует условию');
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота