sooooooyeees
19.09.2022 13:02

Написать программу в паскале abc. вывести на экран все двузначные числа, сумма цифр которых равна заданному числу n

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Ильдар21111
02.10.2020 15:19
Блин! Начал писать программу, а комп ВЫЛЕТЕЛ
Поэтому припоздал

uses Crt;
var i, n, m, z1, z2 :integer;

begin
 ClrScr;
 Write (' n = ');
 ReadLn(n);
 WriteLn;
 if (n<0) or (n>18) then WriteLn (' None!')
 else begin
      for i:=11 to 99 do
         begin
           m:=i;
           z1:=m div 10;
           z2:=m mod 10;
           if (z1+z2=n) then Writeln(' m = ', m);
         end;
      end;
 ReadLn;
end.
0,0(0 оценок)
Ответ:
emilylund829
02.10.2020 15:19
Var
i,j,n:integer;
begin
read(n);
for i:=1 to 9 do
for j:=0 to 9 do
if i+j=n then
Writeln(i,j , ' = ', n);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота