annvs1
24.11.2020 16:39

Напишите программу, которая принимает с клавиатуры целое число и проверяет, на какое количество двузначных чисел оно делится. результат проверки класс должен вывести на экран вместе с соответствующим текстовым сообщением.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Пакета
02.10.2020 15:15
На паскаль
var i,j,k:longint;
begin
read(i);
if i < 10 then write('Число меньше 10. Поэтому оно не имеет двузначный делитель');
for j:=10 to 99 do
if i mod j=0 then inc(k);
if k=0 then write('Ваше число не имеет двузначный делитель') else write('Ваше число имеет ',k,' делителей');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота