kartoshka212
22.01.2021 08:51

Напишите программу которая находит среднее арифметическое всех чисел записанных в файле в столбик и выводит результат в другой файл

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
гуманитарийеп
02.10.2020 14:59
Var
  n,d,s:longint;
  mid:real;
  f:Text;
begin
  n:=0; s:=0;
  Assign(f,'input.txt'); Reset(f);
  while not Eof(f) do begin
    Readln(f,d);
    if not Eof(f) then begin Inc(n); s:=s+d end
  end;
  Close(f);
  Assign(f,'output.txt'); Rewrite(f);
  mid:=s/n;
  Writeln(f,mid);
  Close(f);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота