usenov7777
23.07.2021 10:26

Написать программу в паскале "дано целое число n (> 0). найти наибольшее целое число к, квадрат которого не превосходит n : k^2 < = n. функцию извлечения квадратного корня не использовать. " (используя оператор while) ,

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Михона
23.07.2020 08:28
Var N,k:integer;
begin
  writeln('введите N');
  readln(N); K:=n div 2;
  while k*k>N do
    k:=k-1;
  writeln(k);
end.
{Возможны и другие варианты}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота