yl800845
03.03.2020 19:13

Составить программу по нахождению стороны равностороннего треугольника по периметру. что я сделал не так?

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Аниса2111
26.05.2020 04:45

Переменные с типом integer нельзя делить. Надо вместо integer в разделе var поставить real

0,0(0 оценок)
Ответ:
ShipunovaDaria
26.05.2020 04:45

У равностороннего треугольника все стороны равны, а значит Р=3а, > а=Р/3

Естественно, как указано ниже, а- вещественные число, а Р принимает только целые значения, ибо при выполнения программы компьютером возникнет ошибка.

Program Long side ;

Var a:real;

Var P:Integer;

Begin

Write ("Perimeter of the equilateral triangle") ;

Read(P)

a:=P/3;

Write("The Length Of the equilateral triangle side is equal to" a) ;

end;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота