Fatimochkaananas
05.03.2021 17:08

Люди добрые, решить в pascal. 1) составить программу, которая запрашивает целое двузначное число и на экран выдаёт остаток от деления этого числа на 3.2) за три четверти средний по информатике учащихся 7 классов составил а, b и c соответственно (ввести с клавиатуры). напишите код программы для расчёта среднего за все 3 четверти.(побыстрее, если есть возможность. 20 , )​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nastyankazau112
21.04.2022 06:15
#include <iostream>

using namespace std;

int gcd(int a, int b);

int main()
{
    freopen("input.txt", "r", stdin);
    freopen("output.txt", "w", stdout);
   
    int n;
   
    cin >> n;
   
    for (int i = 0; i < n; ++i)
    {
        int a, b, c, d;
       
        scanf("%d/%d+%d/%d=", &a, &b, &c, &d);
       
        int num = a * d + b * c;
        int den = b * d;
       
        int cur_gcd = gcd(num, den);
       
        num /= cur_gcd;
        den /= cur_gcd;
       
        cout << num;
        if(den != 1)
            cout << '/' << den;
        cout << endl;
    }
   
    fclose(stdin);
    fclose(stdout);
    return 0;
}

int gcd(int a, int b)
{
    if(a == 0)
        return b;
    return gcd(b % a, a);
}
0,0(0 оценок)
Ответ:
сснсогаоаг
22.04.2023 10:06
1.
var x1,x2,x3,y1,y2,y3,a,b,c,p,s:real;
begin
readln(x1,y1);
readln(x2,y2);
readln(x3,y3);
a:=sqrt(sqr(x1-x2)+sqr(y1-y2));
b:=sqrt(sqr(x3-x2)+sqr(y3-y2));
c:=sqrt(sqr(x1-x3)+sqr(y1-y3));
p:=(a+b+c)/2;
s:=sqrt(p*(p-a)*(p-b)*(p-c));
writeln('S=',s,';');
end.

2.
var n,i,j,Sn,si:int64;
begin
readln(n);
Sn:=0;

for i:=1 to n do
begin
Si:=1;
for j:=i to i*2 do Si:=Si*j;
Sn:=Sn+Si;
end;

writeln('Sn=',Sn,';');

end.

Для составления блок-схемы могу объяснить довольно простой алгоритм:
Ты проходишься одной переменной от 1 до n, и в каждом проходе ты
Вычисляешь произведение чисел от значения той переменной до ее удвоенного значения другим циклом
И в конце прохода главного цикла ты прибавляешь к результирующей переменной (которая в начале программы была обнулена) то произведение, которое ты только что вычислил.

P.S. Возможно на словах это звучит довольно-таки непонятно, но для этого есть код, который поясняет весь алгоритм
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота