Написать программу 1. в которой элементы двумерного массива равны сумме квадратов индексов, 2. которая циклически сдвигает заданный одномерный массив на один элемент вправо (при этом последний элемент оказывается на месте первого элемента).
Const m=10; n=6; var a:array[1..10,1..6] of integer; i,j:integer; begin Writeln('Элементы массива'); for i:=1 to m do begin for j:=1 to n do begin a[i,j]:=sqr(i)+sqr(j); Write(a[i,j]:4) end; Writeln end end.
const n = 10; var a: array[1..n] of integer; i, t: integer;
begin Randomize; Writeln('Элементы массива'); for i := 1 to n do begin a[i] := Random(50); Write(a[i]:3); end; Writeln; t:=a[n]; for i:=n-1 downto 1 do a[i+1]:=a[i]; a[1]:=t; Writeln('Результирующий массив'); for i := 1 to n do Write(a[i]:3); Writeln end.