Mraleex
24.02.2020 15:58

25 ! "сообщение" по теме динамика на языке python

в сообщении, состоящем из одних букв и пробелов, каждую букву заменили её порядковым номером в алфавите (а - 1, б - 2, я - 33), а пробел - нулем. требуется по заданной последовательности цифр найти количество исходных сообщений, из которых она могла получиться.

входные данные
в первой строке содержится последовательность цифр. цифр не более 100.

выходные данные
вывести одно число.

примеры
входные данные
80946
выходные данные
1
входные данные
21705
выходные данные
3

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
fgdfc1
28.09.2020 20:09
Потому что в ASCII всего 2^8 = 256 символов (обычно это цифры, символы, латиница большие и маленькие буквы, национальный алфавит большие и маленькие буквы)

в юникоде же все сложнее. UTF-16 действительно занимает 16 бит на символ и имеет в себе 2^16 = 65`536 символов, куда помещается множество алфавитов разных языков, в том числе куча иероглифов, которые в ASCII просто не помещались. Описание наборов символов есть на вики

но есть еще и UTF-8 юникодная кодировка которая организована куда сложнее, занимает по 8 бит на символ для латиницы, но дальше идет расширение. Например символы кириллицы занимают уже по 16 бит

в юникоде есть и другие типы кодировок типа UTF-32LE соответственно 32 бита на символ

так что утверждение что "код Unicode-2 байта на символ" вообще говоря сомнительно без уточнения конкретной кодировки. 
0,0(0 оценок)
Ответ:
tolya22112016
13.11.2022 22:02
Решение на Pascal (если не подходит - скажите):

program pediatr;
var
  h_old, h_new, w_old, w_new: integer;
begin
  write('введите рост ребёнка месяц назад (в см): ');
  readln(h_old);
  write('введите рост ребёнка сейчас (в см): ');
  readln(h_new);
  write('введите вес ребёнка месяц назад (в г): ');
  readln(w_old);
  write('введите рост ребёнка сейчас (в г): ');
  readln(w_new);
  if ( (h_new - h_old) >= 3 ) and ( (w_new - w_old) >= 700) then
    writeln('Ваш ребёнок развивается хорошо')
  else
    writeln('Ваш ребёнок меньше нормы');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота