viktoriacotik1
06.04.2022 18:18

Дано условие и программа, ее решающая. предложить набор тестов для проверки работо программы. составить программу, печатающую значение true, если указанное высказывание является истинным, и false в противном случае: 1. треугольник со сторонами a, b, c является равносторонним. var a, b, c : integer; begin writeln(' a, b, c? '); readln(a, b, c); writeln( (a=b) and (b=c) and (a=c) ) end.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Яна13022016
22.07.2020 12:14
1) вводить три равных натуральных числа - треугольник равносторонний. Результат программы TRUE ⇒ программа работает корректно
2) вводить три неравных натуральных числа - треугольник не равносторонний. Результат программы FALSE ⇒ программа работает корректно

3) ввести три нуля - треугольник не существует. Результат программы TRUE ⇒ программа работает некорректно
4) вводить три равных отрицательных числа - треугольник не существует. Результат программы TRUE ⇒ программа работает некорректно
5) ввести три равных или неравных вещественных числа - треугольник существует. Результата программы нет (ошибка типов) ⇒ программа работает некорректно
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота