1. составьте программу к : «на яблоне было х яблок. в первый день с яблони упало а яблок. каждый следующий день опадало в 2 раза больше яблок, чем в предыдущий. сколько яблок останется через k дней? ».
begin writeln('Введите количество яблок'); readln(x); writeln('Введите количество дней'); readln(k); writeln('Введите количество яблок, которое упало в 1 день'); readln(a);
for i:=1 to k do begin x:=x-a; a:=a*2; end;
writeln(inttostr(x)); sleep(3000);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку