Требовалось написать программу, при выполнении которой с клавиатуры считывается натуральное число n, не превосходящее 10^9, и выводится количество цифр этого числа. программист торопился и написал программу неправильно. var n: longint; sum: integer; begin readln(n); sum : = 1; while n > 1 do begin n : = n div 10; sum : = sum + 1; end; writeln(sum); end. последовательно выполните следующее. 1. напишите, что выведет эта программа при вводе числа 938? 2. укажите одно число, для которого программа будет работать верно. 3. найдите все ошибки в этой программе (их может быть одна или несколько). укажите все строки (одну или более), содержащие ошибки, и для каждой такой строки правильный вариант. обратите внимание, что требуется найти ошибки в имеющейся программе, а не написать свою, возможно, использующую другой алгоритм решения. исправление ошибки должно затрагивать только строку, в которой находится ошибка.