Fox1114
24.03.2022 04:16

Дано действительное число х. напишите программу для вычисления: числа х, округлённого до ближайшего целого числа х без дробных цифр

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ivanov2397
02.10.2020 13:19
В Паскале есть функция Round, которая использует следующий "стандартный" алгоритм округления:
Если число положительное, то при величине его дробной части меньше 0.5, она просто отбрасывается, если больше - отбрасывается и к числу прибавляется единица. Если число отрицательное, то при абсолютной величине его дробной части меньше 0.5, она просто отбрасывается, если больше - из числа вычитается единица.
А функция Trunc возвращает целую часть числа.

var
  p:real;
begin
  Write('Введите число: '); Read(p);
  Writeln('Округленное значение: ',Round(p),', целая часть: ',Trunc(p))
end.

Тестовое решение:
Введите число: -12.74
Округленное значение: -13, целая часть: -12

Введите число: 12.93
Округленное значение: 13, целая часть: 12

Введите число: 9.4323
Округленное значение: 9, целая часть: 9
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота